Tag Archives: Windows 8

Windows 8.1 and Macintosh: Remote Desktop Connection

After upgrading Windows to 8.1 remote connections from my Macintosh using Remote Desktop Connection seized to function. The symptom is, when trying to connect, it complains as follows: “Remote Desktop Connection cannot verify the identity of the computer that you want to connect to”.

There are two workarounds for this.

No. 1: Install the new Client from the Mac AppStore. It works, but I don’t like it because of two annoying flaws. First of all, it opens my present .rdp-Files but doesn’t understand them and throws an error. Second, if it’s in fullscreen mode, unlike with the old client, the Macintosh Dock is not accessible anymore.

No. 2: Set two group policies, as described here by VMware:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2059786

This can be done locally or on the Active Directory Domain Controller (I’m successfully using the latter method). According to Microsoft, this is less secure, in theory.

Windows 8 joining Samba domains, and which ones it just fails to join (those with dots in their names)

TO SAY AS OF MAI 2015

There are two way to get Windows 8 into a NETBIOS/samba3 dot style domain.

  1. Join Windows 7 and upgrade to 8/8.1 – works perfectly.

2a. second method is basically tampering with DNS name resolution temporarily in the network interface settings. There’s a link down in the comments. I can confirm Havrlas method works fine. 🙂 thanks again

2b. for now just an idea, but what about just stopping the DNS-Client in Computer/Manage/Services … haven’t tried that yet, but I will on the next occasion, if it comes before migrating to S4AD.

EDITED JULY 16, 2013

former post name: Windows 8 failing to join certain Samba domains

Usually, Windows 8 can indeed easily be integrated into classic Samba environments, say improved NT4 domains. And, yes, Microsoft has indeed dropped native NT4 support and deliberately developed some sort of compatibility mode to support Samba, it seems.

To enable Samba 3 domain membership, three registry keys have to be changed by the user, whereof we already know two from Windows Seven. The first one, named DomainCompatibilityMode, is quite obvious by it’s name, though its name doesn’t exactly imply how that works. The second one, DNSNameResolutionRequired, is to a lesser degree obscure, but still, its name doesn’t tell us for what exactly DNS names do or do not need to be resolved (sure, DNS is needed to find AD DCs, but that can’t be the whole truth about this regkey). The third one is new since Windows 8, and it’s a rather rude one. It’s a change in the Workstation Service dependencies which results in SMB2 support being disabled as a whole. This requirement results from shortcomings in the SMB2 support in Samba 3.6. While SMB2 support in Samba is considered helpful for Windows 7, it is not compatible to Windows 8’s more advanced implementation. This is at least the case when connecting to a DC, resulting in two options, which are to turn off SMB2 either on the server side (“max protocol = nt1”) or on the client side via the described registry key change.

Continue reading Windows 8 joining Samba domains, and which ones it just fails to join (those with dots in their names)

Join Windows 8 to Classic Samba Domain

applies changes as known from Windows 7, and turns off SMB2. Don’t forget to revert DependOnService to old value before switching to Active Directory. Impacts Performance and maybe Security otherwise.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation]

"_DependOnService_win8orig"=hex(7):42,00,6f,00,77,00,73,00,65,00,72,00,00,00,4d,00,52,\
  00,78,00,53,00,6d,00,62,00,31,00,30,00,00,00,4d,00,52,00,78,00,53,00,6d,00,\
  62,00,32,00,30,00,00,00,4e,00,53,00,49,00,00,00,00,00
"DependOnService"=hex(7):42,00,6f,00,77,00,73,00,65,00,72,00,00,00,4d,00,52,00,\
  78,00,53,00,6d,00,62,00,31,00,30,00,00,00,4e,00,53,00,49,00,00,00,00,00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]
"DomainCompatibilityMode"=dword:00000001
"DNSNameResolutionRequired"=dword:00000000